Virtual Private Server (VPS) setup and working for web site

This past weekend, on Sunday, October 15, while I was at my sister’s house, I decided to purchase a Virtual Private Server (VPS) and migrate from a shared hosting plan to a VPS plan.

The advantage is that instead of sharing resources with other web sites, I will have my own Virtual Private Server with its own dedicated resources.

The big items, that I think were slowing down the site when on a shared plan, was that according to a reverse IP lookup, the shared IP address for my web site was being shared with over 2,000 other web sites.

Now, on a VPS, only the sites I setup are on the IP address, of which at the moment is only one.

There was some confusion since the files did migrate, but the site was still on the shared hosting package, so the web site was running, but the files on the VPS were not what was showing, it was my shared hosting package.

Around Tuesday at noon I started to realize that something seemed wrong, and cancelled the shared hosting package, at which point the web site went offline because I had not setup the DNS on my VPS.

The DNS is where you setup the IP to where everyone’s traffic is directed when they type in the IP name, plus tells the server what IP address to associate with the domain name (the name that ends with a .com usually.)

It took me a few days to figure out how to get the cpanel working, the DNS working, and them correctly modify what they call the A record in the DNS entries.

It was somewhat of a surprised and relief when it all of a sudden started working, since even with the correct DNS entires, sometimes it can take as long as 24 hours for the changes to make it across the Internet.

Louis J. Desy Jr.

Please follow and like us:
0

SSL certificate

Today I just got an SSL certificate and I am working on getting https as the default for accessing the site. The wordpress directory appears to be doing this already, it is the top level that is not defaulting and has mixed content.

Louis J. Desy Jr.

Please follow and like us:
0

Site updates

I finally figured out why Google’s Adsense was not showing any ads after looking at the code, wdigets, plug ins, etc. One web site mentioned checking for an ad blocker, which I forgot I had in place. Once that was disabled for the site, everything was fine.

I also added a subscriber plug in but am not sure how it is different from what is/was already part of the WordPress.

Louis J. Desy Jr.

Please follow and like us:
0